Neuste Android Studio 3.3.2 Fehler: Cause: unable to find valid certification path to requested target

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Neuste Android Studio 3.3.2 Fehler: Cause: unable to find valid certification path to requested target

    Moin Leute,

    1. hab ein frisches Android Studio 3.3.2 installiert.
    2. Dann versuche ich eine neues Project (zB mit Bottom Nav zu erstellen)..
    3. Ausführen, sollte eig. ohne weitere Änderungen einerseits funzen
    -->Run Build

    Shell-Script

    1. Caused by: org.gradle.internal.resolve.ModuleVersionResolveException: Could not resolve com.android.tools.build:gradle:3.3.2.
    2. Required by:
    3. project :
    4. at org.gradle.api.internal.artifacts.ivyservice.ivyresolve.RepositoryChainComponentMetaDataResolver.resolveModule(RepositoryChainComponentMetaDataResolver.java:103)
    5. ... 154 more
    6. Caused by: org.gradle.api.resources.ResourceException: Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.3.2/gradle-3.3.2.pom'.
    7. at org.gradle.internal.resource.ResourceExceptions.failure(ResourceExceptions.java:74)
    8. ... 159 more
    9. Caused by: org.gradle.internal.resource.transport.http.HttpRequestException: Could not HEAD 'https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.3.2/gradle-3.3.2.pom'.
    10. at org.gradle.internal.resource.transport.http.HttpClientHelper.performRequest(HttpClientHelper.java:96)
    11. at org.gradle.internal.resource.transport.http.HttpClientHelper.performRawHead(HttpClientHelper.java:72).....
    Alles anzeigen

    --> Gradle sync Issues
    ERROR: Cause: unable to find valid certification path to requested target

    Leut stackoverflow etc soll ich auf Prject level gradle: maven { url "http://jcenter.bintray.com"} hinzufügen.. keine Lösung bei mir..
  • Wahrscheinlich fehlt google() in deiner build.gradle datei:
    Der Anfang sollte so aussehen:

    Quellcode

    1. buildscript {
    2. repositories {
    3. jcenter()
    4. google()
    5. }
    6. dependencies {
    7. classpath 'com.android.tools.build:gradle:3.3.2'
    8. //classpath 'com.google.gms:google-services:3.1.1'
    9. // NOTE: Do not place your application dependencies here; they belong
    10. // in the individual module build.gradle files
    11. }
    12. }
    Alles anzeigen
  • Hallo,

    ich habe ein Ähnliches Problem.
    Nach vier Jahren musste ich nochmal eine Android Applikation anfassen um dort Änderungen vor zu nehmen. Sowohl mit der Version des damaligen Android Studo als auch mit der aktuellen Version bekomme ich folgende Fehlermeldungen:

    App: Sync failed at 04.04.2019 with 1 error
    Gradle Sync Issues: (1 error)
    Cause: peer not authenticated.

    Alle Lösungsansätze die ich im Internet gefunden habe führten nicht zur Lösung meines Problems

    Android Studio Version 3.3.2
    JDK Version 9.0.1

    Bei einem Build bekomme ich folgende Fehlermeldung:

    Support for builds using Gradle older than 2.6 was deprecated and will be removed in 5.0. You are currently using Gradle version 2.2.1. You should upgrade your Gradle build to use Gradle 2.6 or later.
    Support for builds using Gradle older than 2.6 was deprecated and will be removed in 5.0. You are currently using Gradle version 2.2.1. You should upgrade your Gradle build to use Gradle 2.6 or later.

    FAILURE: Build failed with an exception.

    * What went wrong:
    A problem occurred configuring root project 'Bride'.
    > Could not resolve all dependencies for configuration ':classpath'.
    > Could not resolve com.android.tools.build:gradle:3.3.2.
    Required by:
    :Bride:unspecified
    > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.2/gradle-3.3.2.pom'.
    > peer not authenticated

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Für ein paar Tips die mir helfen könnten das Problem zu beheben würde ich mich sehr freuen.

    Viele Grüße

    Resetpin
  • Hallo und vielen Dank für die schnelle Reaktion,

    Das mit jcenter() hab ich auch im Zusammenhang mit meinem Fehler bei Google suchen gefunden,
    Die dort vorgeschlagenen Veränderungen hatten leider allerdings keinen Effekt.
    Mag natürlich sein, dass ich zusätzlich noch was falsch gemacht habe.

    Auf jeden Fall hänge ich mal meine Gradle-Dateien an vielleicht hilft das weiter.

    Vielen Dank und viele Grüße
    Resetpin
    Dateien
  • Hallo,

    hatte übersehen, dass es da auch noch eines gibt.

    Den Inhalt der Datei build.cradle, welche sich direkt im app-Verzeichnis befindet füge ich direkt nach der Mail ein.

    Herzlichen Dank

    Resetpin

    Quellcode: build.gradle

    1. apply plugin: 'com.android.application'
    2. android {
    3. compileSdkVersion 28
    4. buildToolsVersion '28.0.3'
    5. defaultConfig {
    6. applicationId "com.wika.android.bride"
    7. minSdkVersion 19
    8. targetSdkVersion 28
    9. versionCode 1
    10. versionName "1.0"
    11. }
    12. buildTypes {
    13. release {
    14. minifyEnabled false
    15. proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    16. }
    17. }
    18. }
    19. dependencies {
    20. compile fileTree(include: ['*.jar'], dir: 'libs')
    21. compile 'com.android.support:appcompat-v7:28.0.3'
    22. }
    Alles anzeigen
  • Versuch doch nochmal google() und maven hinzuzufügen. Vielleicht hilft das.
    Sollte dann so aussehen:

    Quellcode

    1. buildscript {
    2. repositories {
    3. jcenter()
    4. google()
    5. }
    6. dependencies {
    7. classpath 'com.android.tools.build:gradle:3.3.2'
    8. //classpath 'com.google.gms:google-services:3.1.1'
    9. // NOTE: Do not place your application dependencies here; they belong
    10. // in the individual module build.gradle files
    11. }
    12. }
    13. allprojects {
    14. repositories {
    15. jcenter()
    16. maven {
    17. url "https://maven.google.com"
    18. }
    19. }
    20. }
    Alles anzeigen
  • Hallo,

    zuerst vielen Dank für die schnelle Reaktion.

    Ich habe mal die von Dir empfohlenen Änderungen in der Datei "build.gradle!" vorgenommen.
    An der Zeile google() scheint er sich zu stören. Da bekomme ich jetzt folgende Fehlerausgabe:

    ERROR: Could not find method google() for arguments [] on repository container.

    Nehme ich google() wieder raus hat sich an meinem Problem leider nichts geändert.
    Ich bin leider mit meinem Latein am Ende und hab keine Ideen mehr wie ich das Problem in den Griff bekommen könnte.

    Bin auf jeden Fall für jede Anregung dankbar.

    Viele Grüße

    Resetpin
  • hallo @Resetpin Du bist ja nicht der thrad ersteller habe das auch nicht gleich bemerkt.


    Wo genau ist denn dein Problem beim neu compilieren deiner alten Alp die scheinbar noch unter einer alten gerade Version geschrieben wurde. Ist die überhaupt mit as oder noch mit eclipsegeschrieben.

    Da in deine gerade fast keine Supportlibs eingebunden werden.

    Du arbeitest auch auf sdk 28 und es kann auch sein das 8oder Zwischenzeit einige Methoden nicht mehr verfügbar sind.
    Beschreibe mal dein Problem genauer.
    Ein Feedback auf Tipps ist auch schön. :P
  • Hallo jogimuc,

    ja ich hab natürlich vorher in diesem Forum gesucht ob mein Problem schon mal behandelt wurde und dieser Thread schien große Ähnlichkeit damit zu haben.

    Ja die alte App wurde von ca. 4 Jahren bereits mit Android Studio geschrieben. Das Installationspaket von damals trägt den Namen: "android-studio-bundle-135.1641136". Ich habe auch zunächst versucht das Projekt wieder mit der alten Konfiguration zu bearbeiten aber offensichtlich gibt es hierbei ein Problem mit der Java Version, was womöglich auch daran liegen mag dass der alte Rechner eine 32-Bit Maschine und der aktuelle eine 64-Bit Maschine ist.

    Da ich bei Bearbeitung der App mit der alten AS Version nicht erfolgreich war hab ich versucht das ganze Projekt auf die aktuelle Version zu heben, was offensichtlich auch nicht so einfach ist. Ich war der Meinung mit einem Import sollte das am besten Möglich sein da hierbei vermutlich alte Teile durch neue ersetzt werden.

    Jetzt zu meinen Problemen.
    Beim Ausführen eines Build->Make Projekt bekomme ich folgede Fehlermeldungen:

    Quellcode

    1. Executing tasks: [assemble]
    2. Support for builds using Gradle older than 2.6 was deprecated and will be removed in 5.0. You are currently using Gradle version 2.2.1. You should upgrade your Gradle build to use Gradle 2.6 or later.
    3. Support for builds using Gradle older than 2.6 was deprecated and will be removed in 5.0. You are currently using Gradle version 2.2.1. You should upgrade your Gradle build to use Gradle 2.6 or later.
    4. FAILURE: Build failed with an exception.
    5. * What went wrong:
    6. A problem occurred configuring root project 'Bride'.
    7. > Could not resolve all dependencies for configuration ':classpath'.
    8. > Could not resolve com.android.tools.build:gradle:3.3.2.
    9. Required by:
    10. :Bride:unspecified
    11. > Could not GET 'https://jcenter.bintray.com/com/android/tools/build/gradle/3.3.2/gradle-3.3.2.pom'.
    12. > peer not authenticated
    13. * Try:
    14. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    15. BUILD FAILED
    Alles anzeigen
    Zudem macht die Syncronisation von Gradle nach wie vor Probleme:


    App: Sync failed at 10.04.2019 with 1 error
    Gradle Sync Issues: (1 error)
    Cause: peer not authenticated.

    Wenn weitere Informationen von meiner Seite nötig um dem Problem auf die Spur zu kommen lasst es mich bitte wissen

    Bis dahin erst mal vielen Dank für Deine/Eure Mühen

    Viele Grüße
    Resetpin

    PS. Hab mal probiert ein neues Projekt mit einer Empty Activity zu erstellen und auch das schläft fehl.
    Folgende Meldung erscheint direkt nach dem Erstellen des neuen Porjektes:

    My Application: Sync failed
    ERROR: Cause: unable to find valid certification path to requested target

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Resetpin ()