Real Time Multiplayer Import existiert nicht mehr: games cannot be resolved

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Real Time Multiplayer Import existiert nicht mehr: games cannot be resolved

    Neu

    Hey,
    folgendes Problem: Ich habe gerade meine SDK Tools aktualisiert und nun habe ich das Problem, dass bei meinen imports überall dransteht "games cannot be resolved". Woran liegt das?
    Ich habe folgende imports drinnen:

    Quellcode

    1. import com.google.android.gms.games.Games;
    2. import com.google.android.gms.games.multiplayer.realtime.RealTimeMessage;
    3. import com.google.android.gms.games.multiplayer.realtime.RealTimeMessageReceivedListener;
    4. import com.google.android.gms.games.multiplayer.realtime.Room;
    5. import com.google.android.gms.games.multiplayer.realtime.RoomConfig;
    6. import com.google.android.gms.games.multiplayer.realtime.RoomStatusUpdateListener;
    7. import com.google.android.gms.games.multiplayer.realtime.RoomUpdateListener;
    MfG
    Timer
  • Neu

    hast du die entsprechenden lib in den dependencies geladen.

    Könnte auch sein das du beim Update Pakete deinstalliert hast . Wenn du im sdk Manager den haken entfernst wird beim Update das Paket gelöscht . Also schau ob alle Pakete die du brauchst auch mit installiert oder mit haken versehen sind
    Ein Feedback auf Tipps ist auch schön. :P

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von jogimuc ()

  • Neu

    Ich habe gerade gesehen, dass es meine dependencies rausgehauen hat. Die wollte ich gerade neu machen nur leider weiß ich gerade nicht mehr, wie das Real Time Multiplayer für Dependencies heißt. Man muss ja immer hinter dem com.google.android... irgendwas schreiben. Ich mein z.B. das hier (der Teil ab :app):

    Quellcode

    1. compile 'com.example.android:app-magic:12.3'
    developer.android.com/studio/build/dependencies.html

    Pakete hab ich nochmal geprüft, habe jedoch nichts gefunden, das fehlt
    Leider finde ich nur Pakete, die angeblich für Real Time Multiplayer benötigt werden, die bei mir nicht aufgelistet sind.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Timer ()

  • Neu

    kann ich dir jetzt auch. Nicht sagen. Von wo hast den Code abgeschrieben vielleicht steht es dort. Oder suche Beispiele auf github dort ist die build Datei bei.

    In dem Video aus dem anderen thread hatte er auch etwas von github geladen schau es noch mal an.

    Du solltest etwas mehr speichern oder über eine versionskontrolle nachdenken.
    Ein Feedback auf Tipps ist auch schön. :P