Android Studio: Gradle project sync failed

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Android Studio: Gradle project sync failed

    Moin zusammen,

    ich wollte mich eigentlich mit dem Android Studio beschäftigen, habe nur seit ein paar Tagen das Problem das nach der Installation, sobald ich ein Projekt starte, immer die Fehlermeldung wie auf dem Bild zu sehen bekomme:



    Versuchen tue ich das ganze auf einem MacBook. Ich habe aktuell die JDK Version 10.0.1 und dieses Gradle über den brew Befehl im Terminal installiert, da dies mit der Android Studio Installation nie mitinstalliert wurde. Zumindest konnte ich dazu nichts finden. Auch mehrere Deinstallationen und wieder neue Installationen haben hier nicht geholfen.

    Inzwischen bin ich echt am verzweifeln und weiß nicht mehr was ich noch probieren kann. :(

    Kann mir jemand hier aus dem Forum vielleicht bei dem Problem weiterhelfen? :saint:

    Für jeden Ratschlag bin ich euch auf jeden Fall sehr dankbar.
  • Hi,

    ich bin zwar auch neu in der Android Welt, aber hoffe kann etwas helfen.

    Bei mir ist das auch so .. nach den Update muss das projekt aktualisiert werden.
    Hast du schon auf den Link unten geklickt "Re-Download depen..." ?

    Wenn Ja versuche ein neues Projekt zu starten und schau ob im neuen Projekt alles funktioniert.

    Wenn im neuen Projekt alles funktioniert kopier den Quelltext ins neue Projekt und schau ob es geht.

    Du hast nicht geschrieben ob neue Projekte auch betroffen sind.

    Gruss Eddi
  • Hi
    Erstmal hast du auch das sdk aktualisiert und auch die richtige Version geladen.
    Zeige mal den Gradle File.

    Diese Fehlermeldung kommt eigentlich wenn nicht die Richtige API version Instaliert ist ?
    Auf welcher API programmierst du ?
    Ist die auch im sdk manager Installiert ?
    Deshalb zeige dein Gadle File sonnst kann ich dir nicht helfen.
    Ein Feedback auf Tipps ist auch schön. :P

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von jogimuc ()

  • Nach einer frischen Installation gehe ich eigentlich davon aus, das alles auf der richtigen Version ist.

    Hier die API und SDK Version:

    Meinst du mit Gradle File das hier?


    Ansonsten ist mir aufgefallen das hier die gradle Version nicht stimmt.



    Hab mal getestet was passiert wenn ich die aktuelle Version (4.8.1) eintrage. Anfang läd der dann neue Dateien herunter, aber später gibt es diverse Fehlermeldung, weshalb ich da dann aufgehört habe weiter dran zu probieren.
  • Hi
    ja das ist das Gradle File was ich sehen wolte.
    Hast du auch das SDK im SDK- Manager installiert?
    ich persönlich arbeite nicht mit API 28 sondern noch mit 27 da API 28 noch Alpha ist und ich zB. im Layout Designer Render Probleme habe, auch sonst sind da noch paar Fehler.
    Ich warte erst mal ab.
    Habe API 28 deinstalliert und 27 installiert.
    Nach einer AS neu Installation ist API 28 meistens Standard und 27 nicht vorhanden. Finde das nicht so sinnig da 28 noch einige Fehler hat. Als Standard sollte eine Stabile Version sein und keine Alpha Version.

    Wenn du 28 deinstalliert hast und ein neues Projekt erstellst wird es dir auch für API 27 erstellt es wird immer mit der hösten Instalierten API erstellt. Oder du änderst das Gradle File von Hand.
    Bilder
    • Unbenannt.jpg

      189,64 kB, 1.051×716, 72 mal angesehen
    Ein Feedback auf Tipps ist auch schön. :P