Android Studio: URI is not registered

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Android Studio: URI is not registered

    Hallo liebe Community,

    ich bin neu hier im Forum und auch völlig neu in der Programmierung für Android.
    Beruflich habe ich schon etliche Jahre Erfahrung mit der Programmierung in verschiedenen Programmiersprachen, u.a. auch Java. Die letzten 2 Jahre habe ich in Java-Script programmiert.
    Nun wollte ich meinen Horizont ein wenig erweitern und auch für Android programmieren. Doch schon vor der ersten Code-Zeile stoße ich auf Probleme.

    Jetzt habe ich bei mir Android Studio 3.4.1 installiert und wollte jetzt mal mit einem einfachen Programm (Hello World) mein Glück versuchen. Leider bekomme ich immer einen Fehler. Dieser Quelltext wurde vom Android Studio automatisch erstellt.

    1 <?xml version="1.0" encoding="utf-8"?>
    2 <android.support.constraint.ConstraintLayout
    3 xmlns:android="http:// schemas.android.com/apk/res/android"
    4 xmlns:app="http:// schemas.android.com/apk/res-auto"
    5 xmlns:tools="http:// schemas.android.com/tools"
    6 android:layout_width="match_parent"
    7 android:layout_height="match_parent"
    8 tools:context=".MainActivity">
    9
    10 <TextView
    11 android:layout_width="wrap_content"
    12 android:layout_height="wrap_content"
    13 android:text="Hello World!"
    14 app:layout_constraintBottom_toBottomOf="parent"
    15 app:layout_constraintLeft_toLeftOf="parent"
    16 app:layout_constraintRight_toRightOf="parent"
    17 app:layout_constraintTop_toTopOf="parent" />
    18
    19 </android.support.constraint.ConstraintLayout>

    (das Leerzeichen nach http:// ist im Quelltext natürlich nicht vorhanden. Das mußte ich hier im Post eingeben, damit da kein Link daraus erzeugt wird.)

    Der Fehler liegt ganz offensichtlich in den Zeilen 3-5. Die Zeilen 6-8 funktionieren auch nicht (sind rot eingefärbt), aber das sind Folgefehler.
    Wenn ich auf einen der roten Zeilen gehe, wird mir folgendes angezeigt:
    "URI is not registered (Settings | Languages & Frameworks | Schemas and DTDs)"
    Auf der genannten Seite der Settings ist (vom System) folgendes eingestellt:

    External Schemas and DTDs: kein Eintrag
    Ignored Schemas and DTDs: relaxng.org/ns/compatibility/annotations/1.0

    Wo liegt die Ursache für diesen Fehler? Fehlen mir irgendwelche Berechtigungen?
    Was muß ich da noch eintragen, damit Android Studio bei mir funktioniert?
    Alle Hinweise, die ich über Google gefunden habe, brachten leider keinen Erfolg.
    Für jeden Hinweis, der mich der Lösung näher bringt, wäre ich sehr dankbar.

    Für Eure Hilfe danke ich Euch im Voraus.
    C3PO
    Code long & prosper O:-)

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von c3po ()

  • Hallo willommen im Forum.
    Wenn das vom Studio selbst erstellt ist. Würde es ich sagen das es mit deiner studio installatio zu tuhen hat. Speziell mit dem sdk. Und dem gradle file.
    Das was du da hast ist nur das Layout in xml und noch kein Java.

    Wenn das schema nicht gefunden wird stimmt was mit dem sdk oder gradle nicht.
    Ein Feedback auf Tipps ist auch schön. :P
  • Hallo jogimuc,

    vielen Dank schonmal für die Antwort.


    jogimuc schrieb:

    Das was du da hast ist nur das Layout in xml und noch kein Java.
    Ja, ich weiß. Ich habe halt den Teil kopiert, wo der Fehler angezeigt wird.

    Der Java-Code ist hier (MainActivity.java)

    import android.support.v7.app.AppCompatActivity;
    import android.os.Bundle;

    public class MainActivity extends AppCompatActivity {

    @Override
    protected void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    setContentView(R.layout.activity_main);
    }
    }


    Aber ich befürchte, das hilft nicht weiter.

    jogimuc schrieb:

    Wenn das schema nicht gefunden wird stimmt was mit dem sdk oder gradle nicht.
    OK, wie kann ich das prüfen und beheben?
    Code long & prosper O:-)
  • Versuche mal ein neues Projekt zuerstellen. Wenn das auch nicht geht ist mit der Installation was nicht in Ordnung.
    Bist du überhaupt online und hast auch alle Updates gemacht. Und vor allem ist das sdk komplett installiert. S haue in den sdk mannager.

    En von Android selbst erstelltes Projekt muss gehen ohne das du da was änderst.
    Ein Feedback auf Tipps ist auch schön. :P
  • jogimuc schrieb:

    Versuche mal ein neues Projekt zuerstellen.
    Habe jetzt mehrere verschiedene Projekte erstellt. Bei Allen das Gleiche.


    jogimuc schrieb:

    Bist du überhaupt online
    Eigentlich ja. IE und FF keine Probleme, auch Outlook geht.
    Aber: Ich bin hier im Firmennetzwerk. Es ist nicht auszuschließen, daß eine Firewall blockt oder der Proxy nicht richtig konfiguriert ist.
    Diese Meldung im AS deutet darauf hin: "ERROR: Unknown host 'services.gradle.org'. You may need to adjust the proxy settings in Gradle."


    jogimuc schrieb:

    S haue in den sdk mannager.
    Habe ich gemacht. Android SDK Tools (24.4.1) ist installiert.
    Im Log ist aber wieder der Hinweis auf einen unknown Host zu sehen: "Failed to fetch URL dl.google.com/android/repository/addons_list-2.xml, reason: Unknown Host dl.google.com"
    Leider bin ich nicht berechtigt (und damit auch nicht in der Lage), den Proxy anzupassen. Ich habe auch netzwerktechnisch nicht das Wissen um den Netzwerk-Leuten zu sagen, was ich brauche.

    Das bringt mich zu der Frage, ob man AS so konfigurieren kann, daß es auch offline läuft oder ob es eine Alternative zu AS gibt, mit der das möglich ist.
    Code long & prosper O:-)
  • achso im Firmen Netzwerk. Das ist bestimmt schwieriger. Hatte ich auch mal versucht war bei mir zwecklos.
    Frage wieso ist bei dir sdk 24 installiert? Normalerweise wird bei einer Standard Installation von Android studio momentan das sdk 28 installiert.

    In der aus dem Netz geladenen install exe ist nur das Studio. Das sdk wird normalerweise beim ersten Start vom studio selber aus dem Netz gezogen. Wenn es fertig ist hast du eigentlich sdk 28 drauf. Müsstest du auch im Manager sehen. Wenn da nur bei 24 ein haken ist . Ist da schon was schief gegangen bei der Installation.
    Oder hast du ein altes Studio mit integrierten SDK genommen.
    Wenn ja das geht nicht mehr.

    Offline arbeiten geht dafür musstest du aber auch erstmal alles runter geladen haben. Was wohl momentan dein Problem ist.

    Ich weiss jetzt nicht genau wie du das sdk von hand runter laden kannst und es installiert. Habe ich noch nicht gebraucht.


    Was passiert Wenn du im sdk Manager etwas installieren willst?
    Ein Feedback auf Tipps ist auch schön. :P

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von jogimuc ()

  • jogimuc schrieb:

    Was passiert Wenn du im sdk Manager etwas installieren willst?
    Das geht nicht. Alles was ich auswählen kann (ist nur Android SDK Tools) ist installiert.
    Werde Alles noch mal löschen und neu installieren. Mal sehen, was dann geht. Aber erst nächste Woche (wegen Urlaub).
    Bis dahin erstmal vielen herzlichen Dank - ich melde mich dann wieder. :thumbsup:
    Code long & prosper O:-)
  • Na dann schönen Urlaub :)

    Wenn du das Studio löscht und installieren willst vergesse nicht die Ordner mit dem Punkt in deinen User Verzeichnis zu löschen. Das macht das Studio nicht. Und bei der Neuinstallation könnte somit der alte Fehler wider da sein.

    Noch etwas sollte das laden des sdk auf dem Firmenrechner nicht aus dem Studio gehen. Kannst du auch den online sdk Manager versuchen.

    androidsdkmanager.azurewebsites.net
    Ein Feedback auf Tipps ist auch schön. :P

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von jogimuc ()