Crash Imageview

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Crash Imageview

    Hallo,
    ich schreibe gerade eine kleine App, die ein Imageview (in einem RelativeLayout) enthält. Wenn ich den Imageview ScreenCenter positioniere funktioniert alles ganz wunderbar. Aber wenn ich es relativ zu einem anderen Element oder an den Rand setze, dann crashed mir der Emulator und/oder das Smartphone. Ich kann mir das Verhalten nicht erklären, ich ändere auch nichts am XML File das mir Eclipse erzeugt.

    Hat jemand eine Idee an was das liegen könnte?

    Thx
  • Normalerweise dynamisch mit dem Eclipse Design Editor.

    Logcat sagt:

    Quellcode

    1. 08-17 11:55:38.540: E/AndroidRuntime(2888): java.lang.RuntimeException:
    2. Unable to start activity ComponentInfo{de.xxx.yyy/de.xxx.yyy.MainActivity}:
    3. java.lang.ClassCastException: android.widget.ImageView cannot be cast to android.widget.TextView
  • Hi Trysis,

    Normalerweise dynamisch mit dem Eclipse Design Editor.


    Ok das meinte ich nicht mit dynamisch.
    Für mich bedeutet dynamisch ein Layout das erst ZUR Laufzeit erstellt wird. Alles was mit dem Design Editor erstellt wurde ist statisch es existiert also schon BEVOR die Anwendung läuft.

    Zu deiner Fehlermeldung:
    Dein Programm stürzt ab weil du einer deine ImageView zu einer TextView casten(umwandeln) möchtest.
    android.widget.ImageView cannot be cast to android.widget.TextView


    Lösung:
    Benutzt du zwei mal die gleiche Id oder hast dich beim findViewById Aufruf verschrieben bzw die falsche Id ausgewählt?

    Ohne mehr Code kann ich dir da leider nicht weiterhelfen.

    Mfg Titus
  • Huhu,
    also ich habe jetzt einfach mal in der OnCreate Methode alles auskommentiert. Dann das Layout so gemacht wie ich will und alles einzeln nacheinander wieder aktiv gemacht. Geändert habe ich an sich nichts, aber es funktioniert komischerweise. Keine Ahnung warum, aber ich vermute das es tatsächlich eine doppelte ID oder ein Dreckfuhler beim FindById war.

    Danke für die Hilfe beim Fehlersuchen.