Eclipse macht ärger

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Eclipse macht ärger

    Hallo,
    Ich wollte grade mall wieder ein bissen an meinem App bastelt und jetzt die Aktuellen Änderungen im Emulator testen. Und dann das:

    Quellcode

    1. Your project contains error(s), please fix them before running your application.

    Also habe ich in den "Package Explorer" geschaut. Da wahr hinter meinem Project aber nur ein Ausrufezeichen in einem Wahndreieck. Dieses Zeichen
    kommt aber auch wenn ich nur eine variable deklarire die ich dann nicht nutze. Im Klartext:
    Keiner sagt mir ob und wo der Error liegt. Was jetzt?

    Wass ich versucht habe:
    • Source > Clean Up...
    • Projekt löschen und neu importieren (hat schon oft geholfen)
    • Source > Organize Imports
    • Debug


    Noch ideen was ich machen könnte ???? :-!
  • Hi XDeveloper,

    nutzt du eine externe Lib in deinen Projekt? Falls ja haste die du sie vielleicht verschoben?

    Haste mal in die R.java geschaut ob du irgend einer id bzw bezeichner einen Namen der Umlaute enthält vergeben hast?

    In der Error View von Eclipse wird in der Regel angezeigt was das Problem ist bzw womit Eclipse ein Problem hat.

    Ach so und du könntest versuchen ob Projekt -> clean dein Problem löst.

    mfg titus
  • Schau dir bitte mal das bild im Anhang an. Das passiert manchmal wenn ich Eclipse starte mit meinem Project Ordner.
    Ich muss ihn dann entfehrenn, und das Project neu importieren. :(

    Ich dass bei euch auch so?

    PS:
    Projekt -> clean hat leider nichts gebracht und eine externe Lib verwende ich auch nicht. Trotzdem Danke @titus
    Dateien
    • EclipseFehler.JPG

      (14,18 kB, 776 mal heruntergeladen, zuletzt: )
  • Ich schätze du hast irgendeinen Error in einer Activity.
    Kannst du mal den Errorlog posten. Ist ja neben Logcat.Dann sollten die Fehler dann angezeigt werden.;)
    MfG,
    Christopher

    Eine gewisses Maß an Freundlichkeit kann man auch von Menschen im Internet erwarten.
    Das Forum basiert komplett auf der Freiwilligkeit ihrer Nutzer und diese sollen sich wohlfühlen! Daher seid bitte freundlich. Danke
  • Startest du direkt mit dem Run-Button von Eclipse?
    Probiere auch mal mit dem Pfeilchen daneben die Liste aufzuklappen und mach mal Run Configurations...
    Schau mal, was als Target für dein Projekt eingestellt ist - vielleicht macht das Ärger.

    Nachfrage zu deinem Screenshot: was meinst du denn da genau?
    Da fehlt m.E. ein res-Ordner und eine Manifest. Ist das überhaupt ein Android-Projekt???
    Das Leben kann so hart sein, man muss nur richtig wollen!!!
  • zum Screenshot

    UweApps schrieb:

    Da fehlt m.E. ein res-Ordner und eine Manifest. Ist das überhaupt ein Android-Projekt???

    Ist echt komisch. Ne Projekt Datei ist dass schon. Wenn ich mit dem Windows Datei Explorer in den Ordner der Workspace gehe werden alle Ordner + Mainfest Datei angezeigt. Das liegt an Eclipse!
    Um die Gesamte Struktur anzeigen zu lassen muss ich den Ordner wieder aus Eclipse entfernen und das Projekt neu importieren. -nervig-

    PS: Wenn ich zuhause bin poste ich euch meine Errorlog.

    Danke für eure Hilfe. :D
  • Dann versuche doch verher noch mal in Eclipse einen Refresh der Packageliste - findest du im rechts-Klick auf Projekt...

    Achja - da gibt es noch was:
    in der Package-Liste ganz oben ist ein kleiner Button mit so komischen Kringeln - hast du da schon mal drauf geklickt?
    Der Button arbeitet mit der Mylin-Taskliste zusammen und schränkt den View ein auf die aktuelle Aufgabe...
    Wenn du mit der Maus auf das Projekt oder einen Ordner kommst, erscheint dann ein kleines +-Symbol hinter dem Eintrag?
    Das Leben kann so hart sein, man muss nur richtig wollen!!!
  • Aha !!! Ich habe was herausgefunden.
    Im Tab "Projects" werden in meinem Project Ordner nur 3 Ordner angezeigt (src, gen, android.jar).
    Im Tab "Package Explorer", werden alle Ordner und Dateien Angezeigt. Wie im Windows Datei Explorer.

    Jetzt zum Tab "Error Log":
    Eine Nachricht ist vorhanden:

    Quellcode

    1. org.eclipse.core.internal.resources.ResourceException: Resource '/knueppel/res' does not exist.
    2. at org.eclipse.core.internal.resources.Resource.checkExists(Resource.java:320)
    3. at org.eclipse.core.internal.resources.Resource.checkAccessible(Resource.java:194)
    4. at org.eclipse.core.internal.resources.Container.members(Container.java:266)
    5. at org.eclipse.core.internal.resources.Container.members(Container.java:249)
    6. at com.android.ide.eclipse.adt.internal.sdk.Sdk$6.run(Sdk.java:1196)
    7. at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


    Ideen ?
  • ich habe die doppelte Verschachtelung aufgelöst.
    Bleibt nur noch folgende Meldung

    Quellcode

    1. org.eclipse.core.internal.resources.ResourceException: Resource '/knueppel/res' does not exist.
    2. at org.eclipse.core.internal.resources.Resource.checkExists(Resource.java:320)
    3. at org.eclipse.core.internal.resources.Resource.checkAccessible(Resource.java:194)
    4. at org.eclipse.core.internal.resources.Container.members(Container.java:266)
    5. at org.eclipse.core.internal.resources.Container.members(Container.java:249)
    6. at com.android.ide.eclipse.adt.internal.sdk.Sdk$6.run(Sdk.java:1196)
    7. at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

    Ich habe mit der Suchfunktion mein Projekt durchsucht. aber nichts mit /knueppel/res
  • Ok ich habe auf Clean gedrückt. Danach kamen zwei Errors in dem "Error Log":

    Quellcode

    1. !ENTRY org.eclipse.m2e.logback.appender 4 0 2012-03-09 14:08:44.138
    2. !MESSAGE Error changing index details central|http://repo1.maven.org/maven2
    3. !ENTRY org.eclipse.m2e.logback.appender 4 0 2012-03-09 14:08:44.141
    4. !MESSAGE Could not add repository index

    Ich werde jetzt eine neues Projekt erstellen und alle Klassen neu kopieren. ;(